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Software Release Notes (Version 40.04.08, Date 26th August 2014 ) 

 

Spirent Attero and Attero-X Powered by Calnex 

IP/Ethernet Network Emulation and Impairment solution 
 

New Features added in this release 

 Filter Ranges & Wildcards 

 Profile Jitter 

 Improved Profile Jitter Algorithm 

 Extended Delay Mode 

 Simultaneous Port Link Flap 

 4 Profile Option 

 Support for latest “Spirent version” of Wireshark 

 Enhanced Statistics and Results 

 Support added for Win 8.1 

 NOTE: Win XP no longer supported 

 

All new features are described in the User Manual which is accessed from the Help Menu of the 

Attero Application Software. Some brief operational notes are provided in the following pages. 
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Filter Ranges and Wildcards 
Filters created by Flow Wizard or Filter Builder, or by importing a PCAP, can include ranges and 

wildcards expanding the filter criteria to match a wider range of traffic.  One example is to filter 

on a range of IP addresses (or a subnet of IP addresses).  Another example is to filter on a 

contiguous range of VLAN ID’s or a non-contiguous range of IP addresses. 

Entering a subnet range of IP addresses and entering wildcards using Filter Builder 

 

1. Annotation “1” above illustrates how to enter wildcards in the MAC Destination and Source 

Address fields.  A wildcard is entered using the * character (asterisk). It can be entered in any 

combination of MAC address fields. Each wildcard matches any byte value for that part of 

the address field. 

2. Annotation “2” illustrates how to enter a range of IPv4 Source Addresses. The address is 

entered in dot-decimal notation followed by an optional CIDR (Classless Inter-Domain 

Routing).  Entering the address without CIDR will set one unique IP address to be used. 

Entering with a CIDR value will set a range of IP address values. 

The above example illustrates an IP Source Address of 192.168.128.0 with a CIDR value of 17 

bits.  This will set a range of IP Source Addresses from 192.168.128.0 through to 

192.168.255.255  - that is 32,768 contiguous addresses. 

A smaller address range can be set by using a bigger CIDR value. 

E.g.  192.168.128.0/24 covers the range 192.168.128.0 through 192.168.128.255  

(A range of 256 contiguous IP addresses). 
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3. Annotation “3” on the previous page illustrates how to enter wildcards in the IP Destination 

Address fields. A wildcard is entered using the * character (asterisk). It can be entered in any 

combination of IP address fields. Each wildcard matches any byte value for that part of the 

address field. 

Note that wildcards and CIDRs are mutually exclusive on the same IP Address field; for 

example 192.168.3.*/17 is not allowed. 

 

4. IPv6 Address fields also accept wildcards and CIDR ranges in the same way as IPv4 Address 

fields. 

5. Wildcards and CIDR ranges can also be entered directly into Flow Wizard by editing the Filter 

fields as shown on the previous page (annotated “a”). 

6. Non-contiguous ranges of IP addresses and MAC addresses can also be entered using Flow 

Wizard. The range is entered using commas to separate the values. The range must be 

within the same Octet/Byte. (E.g. 192.168.100.1,  192.168.100.5, 192.168.100.255) 

 

Entering a VLAN ID range 

 

1. Enter the VLAN ID range in Filter Builder using the “-“ character between the min and max 

values of the contiguous range as shown in the graphic above annotated “1”. 

A non-contiguous range can also be entered using “,” as a separator. (E.g.   1,3,7,100) 
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Note that the range must be contiguous and lie within the limits below; 

0-255 

256-511 

512- 767 

768-1023 

1024-1279 

1280-1536 

 … 

 … 

3583-3838 

3839-4095 

Any range that crosses over the limit boundaries given above is invalid (e.g. 250-260 is an 

invalid VLAN ID filter range in Attero). 

A VLAN ID range can also be entered directly to Flow Wizard by editing the Filter fields as shown 

on the previous page (annotated “c”). 
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 Jitter 
 Independent jitter level and distribution can be set on each Profile (Gaussian, Gamma, 

Uniform, Step). 

 Applied Jitter readout correlates directly to STC. (Max/Min Jitter Results) 

 

Adding jitter to a single profile; 

Click on the Fixed Delay and Jitter impairment element to access the Jitter Impairment Set-

up view shown below. 

Jitter is added to an impairment profile by first selecting the distribution type and 

parameters, then generating a profile of Jitter points that is downloaded to the Attero 

hardware. 

Follow steps 1 to 7 below to generate and download a Jitter profile to the Attero hardware. 

 

1. Click on the Jitter checkbox. 

2. Choose the Jitter Distribution type for the profile to be generated by clicking on the 

appropriate radio button. Each type displays a graph that illustrates the shape of the 

distribution and also the relationship between the values; Fixed Delay, Mean, Max and 

Standard Deviation etc. 

Note that the Gaussian distribution is bounded by the Max and Min values (Truncated 

Gaussian distribution). 
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3. Enter the parameters to be used to create the Jitter distribution profile. 

Explanation of fields; 

Max (µs) – sets the Maximum Delay value of the Jitter Profile. 

The maximum value that can be set is the Fixed Delay value plus 107ms. (Resolution 0.1µs) 

 

Fixed Delay – this field displays the value of Fixed Delay that is set (if any). The jitter profile is 

superimposed on top of the Fixed Delay. 

Mean (µs) – displays the Mean Delay value. 

Std Dev (µs) – sets the spread of the jitter distribution. 

Points – sets the number of points in the jitter distribution profile (range 2 – 1-024) 

For the Jitter Generation option parameters shown on the previous page all packets would 

have a minimum delay of 200µs (Fixed Delay) and a jitter delay value somewhere between 

0µs and 100µs (Max minus Fixed Delay). The Fixed Delay and Jitter values are added together 

to get the total delay so the actual delay range would be from 200µs to 300µs. 

 

4. Click on the Generate button to create the profile of jitter values to be used. (If 1024 

“points” was chosen in step 3 then 1024 values will be created in the profile). 

At this point the profile can be displayed in a table, TIE graph or PDF (Probability Density 

Function) graph by clicking on the Display button.  When the table of points is displayed click 

on Graph->Show Graph in the Menu Bar to view the generated profile as a Delta Delay (TIE) 

graph, or click Tools->Plot PDF/CDF/Histogram to view a PDF. 

Note that the profile table & graphs do not include any Fixed Delay component. Only the 

Jitter component is displayed. See Error! Reference source not found. for more general 

details on Displaying Graphs. 

The Generated profile can also be exported, edited and re-imported. To export ensure the 

table/graph of generated values is displayed then use File->Export from the Menu Bar and 

save as .csv file.  To import click on Import and select the required .csv file 

See section on Error! Reference source not found. on page Error! Bookmark not defined. for 

details on how to manually edit a Jitter Profile. 

To exit the table/graph view click on the Impairments button located in the workflow area.  

5. Key information about the profile values generated is displayed. These values correlate 

directly to the Spirent Test Center results fields as follows; 

Attero  Spirent Test Center 

Max Delay  Max Latency 

Min Jitter Min Jitter 

Max Jitter Max Jitter 

 

6. Steps 3 and 4 can be repeated adjusting the parameters to achieve the desired profile. 

7. Click on the Apply button to save the generated jitter profile to the Attero unit. 

 

 Click on <<Control to return to the Impairments Summary View. 

 When all required impairments have been added to the profiles click on    to 

apply the Impairment Profiles to the traffic flowing through the Attero. 
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Extended Delay Mode 
 Add up to 400 seconds Delay (100M/1G/10G) 

Example; Add 2 seconds delay at 4Gb/s Line Rate. 

 

In normal operation Attero provides a fixed maximum limit of delay that can be flexibly 

applied across the configured profiles on each port. For example when set to 1Gb/s 

interface Attero provides a maximum limit of 8 seconds delay – that could be 8s on one 

profile, 1s on each of 8 profiles, or any other configuration of delay that adds up to 8s 

maximum. In this mode of operation the Attero’s fixed maximum limit ensures that all 

packets pass through Attero right up to the full Line Rate (1Gb/s). No packets are 

unintentionally dropped. 

In scenarios where the full Line rate of traffic is not required Attero’s Extended Delay 

Mode allows the user to add higher levels of delay. This is done at the expense of the 

maximum rate of traffic that can pass through Attero without dropping packets. For 

example in Extended Delay Mode it is possible to set 16 seconds of delay on the 1Gb/s 

interface (twice the normal limit). The maximum traffic rate possible with this delay 

setting is 500Mb/s (half the normal limit).  At traffic rates higher than 500Mb/s some 

packets will be unintentionally dropped. 

 

The formula for calculating the Max Delay and Traffic Rate using the 1Gb/s interface is; 

Max Delay (seconds) x Traffic Rate (bandwidth in Gb/s) = 8 (constant) 

Some examples; 

Delay Bandwidth 

400s 20Mb/s 

160s 50Mb/s  

80s  100Mb/s 

16s  500Mb/s 

8s  1Gb/s 

2s  4Gb/s 

 

Adding Fixed Delay in Extended Delay Mode 
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1. Enter the value of Fixed Delay required as shown annotated above. 

If the value of Fixed Delay entered is greater than the Available delay the Attero will 

automatically prompt the user to confirm changing to Extended Delay Mode.  Note that 

adding Jitter also uses up the Available delay which can result in switching to Extended 

Delay Mode when jitter is selected. 

2. To change to Extended Delay Mode click on Yes. 

 
3. When in Extended Delay Mode the display of Remaining delay changes to an indicator that 

Extended Delay Mode is set as shown illustrated below. 

 

 

4. If the user chooses NOT to enter Extended Delay Mode in step 2 by clicking on No the 

following prompt is displayed and no change is made to the Fixed Delay setting; 

 

 

Note that it is possible to re-allocate more memory to a particular profile to achieve more Fixed 

Delay on that profile without entering Extended Delay Mode. This is done by clicking on the 

Memory Allocation button shown encircled in the graphic on the next page. 
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Simultaneous Port Link Flap 
 This function can be used to test network failover.  Time difference between Attero Port1->2 

and Port2->1 optical interfaces switching off is < 1msec. (Typical target for overall network 

failover switching is 50msec). 

 

Adding Link Flap or Link Down impairment; 

Click on the Corruptions impairment element to access the Impairment Set-up view shown 

below. The Link Flap impairment is selected from the Physical Corruption menu. 

 

 

1. Tick the Physical Corruption checkbox. 

2. Select Link Flap. 

3. Choose Constant Distribution and Continuous Periodicity for “Link Down” function or select 

On/Off Repeat Periodicity for a Flapping function. 

4. Repeat the above for the other Attero Port for Simultaneous Dual Port Link Flap. 

5. Click on     to start the Link Flap on both ports. 
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4 Profile Option 
 More flexible product options are now available; 

16, 8 or 4 profiles can now be ordered.  These are named AI, I and B respectively as 

shown below. 

 
 

 
 
Support for latest “Spirent version” of Wireshark 

 Attero now supports both 1.10.3-Spirent and 1.6.9-Spirent versions of Wireshark. 

Version 1.10.3-Spirent is included on the Software CD that ships with the Attero product. 
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Enhanced Statistics & Results 
 Separate traffic results for each port. 
 More Port and Profile Counts, Rates etc. 

 Rx and Tx bandwidth and packet rate for each Profile. 

 Results in bits/sec or Mbits/sec 

 Bandwidth results can now calculated using L1 Bytes. 

 Freeze Display 

 Elapsed Time Counter 

 Saved results File 
 

Examples of the above features are shown in the graphics below. 

 
1. Profile Packet Counters are now always enabled (these used to be disabled if no corruptions 

were applied). This means packets can now be counted on profiles that only have Fixed 
Delay applied. 

2. Use the Freeze button to freeze the display.  The counters still run in the background. The 
Freeze button legend changes to Unfreeze when active. Click Unfreeze to resume normal 
display update. 

3. The Elapsed Counter displays the time since Start Impairments or the last Reset Counters 
action. 
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4. Port level Packet and Byte Rate counters have been added. This makes it easy to see 
the total number of packets and the byte rate (bandwidth) of the traffic at each 
port. 

5. All results that are “Rate” based can be viewed in either Mbits/sec or Bits/sec. 
For example Input Byte (Rate). 

6. Layer 1 Bytes can now be optionally included in “Byte Rate” based results. 
7. A count of the Byte Rate and Packet Rate passing through each profile is displayed. 

These counts are displayed even when the Bandwidth Control impairment is not 
selected so they can be viewed at all times. 


	Filter Ranges and Wildcards

